5th May 2020

Performance issues

We are experiencing some performance issues. We are looking for a cause.

Update: we've identified the issue

Update: the issue is fixed; monitoring

Update: the issue is fixed.

Report Incident